Farm issue

Home Forums Bugs Farm issue

Tagged: 

This topic contains 9 replies, has 3 voices, and was last updated by Radu 2019-02-19 at 4:24 pm.

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #1251
    Garies
    Garies
    Moderator

    I still have issues where the farm just “looses” the planted crops.

    I’ve had fully grown aubergines, left it there for a bit, placed some generators etc. and it started raining, when I noticed there was no crops..
    So I just thought of replanting it, but as soon as I plan it, it dissapears…
    So it tested with carrots, same thing…
    Made small clip, and also have my log file:
    (Same folder as the visual issues I’ve logged)

    https://drive.google.com/drive/folders/1NS3NLTuIAkQWD1ww87os7mq-gikgGfO2?usp=sharing

    #1252
    Garies
    Garies
    Moderator

    Update: After rain event I re planted aubergines, and now its working again.

    #1254
    Radu
    Radu
    Creator

    You’re so lucky that you get rain, I’ve been playing for tens of hours and didn’t get one single rain drop :(

    Anyway I’ve encountered the same thing just a few moments ago while I was playing. I planted carrots, went to explore a bit and when I came back they were gone. I looked into it at first, thinking it was due to the player going too far, or the nox event, or the farm tech being unlocked while a crop was planted but nothing could explain the bug. But I never had what you showed in the clip! That’s even worse…

    I’ll look some more into it today and try and figure out what’s causing this crop failure. Was about to push a cool new patch too :(

    #1257
    Garies
    Garies
    Moderator

    Lolz, I’m sorry, well I’m not too fond of rain, so you can have mine :P

    I’m glad that mine is “worse” he he, but yeah, quite irritating..

    Ah, sorry about the cool patch..

    Busy recording also, so will have another episode tomorrow..
    Maybe with the next patch I can do another UNI.. (I felt the last one didn’t have enough for a UNI)

    #1258
    Radu
    Radu
    Creator

    Haha it’s alright! I figured it out, it was indeed because of the rain. The rain is supposed to put out fires, but would sometimes destroy entire objects oops haha. It’ll be part of the next patch!

    #1261
    Garies
    Garies
    Moderator

    makes sense why some of my assemblers also takes damage for no reason :D

    But thanx for the quick solution :)

    #1342
    Runeshadow
    Runeshadow
    Participant

    I have a slightly different farming issue. Unlocked Chile, tried to sow. I could see the plants appeared for a second, then disappeared

    Let me try this Google Drive thing LOL

    https://drive.google.com/file/d/1DsXWk4zYOh6-y9fZ3IsXidEakGz59dSM/view?usp=sharing

    #1343
    Radu
    Radu
    Creator

    Thanks that’s a known issue, just a visual artifact ^^ Going to get around to it eventually.

    Edit: I still can’t reproduce this farm reset issue even after spending 2 hours on it. I added some safety checks to the code as well as some debugging info every time a crop disappears. So if the bug occurs again, please send me your log file and it will hopefully tell me what made it disappear!

    #1354
    Runeshadow
    Runeshadow
    Participant

    OK cool on the visual issue.

    I also have the grown Aubergines disappeared after reloading a saved game. I noticed it in the last build. re-planted the farm, got the new update, reloaded the game and they disappeared again

    #1356
    Radu
    Radu
    Creator

    Okay I think it’s fixed now. There was an issue introduced by one of my optimizations a few weeks ago that made crops be destroyed on load and then remade, but crops in the farm would never be remade. Hopefully this bug that you had is the same as Garies. Going to push a little patch just for this now, later today or tomorrow

Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.